<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<meta charset="utf-8" />
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-26466179-18"></script>
<script>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments)};gtag("js", new Date());gtag("config", "UA-26466179-18", {"groups":"default","anonymize_ip":true,"allow_ad_personalization_signals":false});</script>
<link rel="canonical" href="https://www.cherokeescout.com/sports/david-browns-ufc-rankings-xplainations-updated-22821" />
<meta name="description" content="In deciding how to rank, I look at head-to-head matchups first, then fights over the last few years, giving more credence to recent ones." />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="text/javascript">
// Initialize the google variables.
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
// Add a place to store the slot name variable.
googletag.slots = googletag.slots || {};
(function() {
  var useSSL = "https:" == document.location.protocol;
  var src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
  document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>
<script type="text/javascript">
  
  googletag.slots["cni_cherokeesidebarnetwork2"] = googletag.defineSlot("//116205717/CNI-Cherokeesidebarnetwork2", [300, 250], "js-dfp-tag-cni_cherokeesidebarnetwork2")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_cherokeepromo"] = googletag.defineSlot("//116205717/CNI-Cherokeepromo", [300, 100], "js-dfp-tag-cni_cherokeepromo")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_cherokeesidebar3"] = googletag.defineSlot("//116205717/CNI-Cherokeesidebar3", [300, 250], "js-dfp-tag-cni_cherokeesidebar3")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_cherokeesidebarnetwork1"] = googletag.defineSlot("//116205717/CNI-Cherokeesidebarnetwork1", [300, 250], "js-dfp-tag-cni_cherokeesidebarnetwork1")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_cherokeesidebar2"] = googletag.defineSlot("//116205717/CNI-Cherokeesidebar2", [300, 250], "js-dfp-tag-cni_cherokeesidebar2")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_cherokeesidebar1"] = googletag.defineSlot("//116205717/CNI-Cherokeesidebar1", [300, 250], "js-dfp-tag-cni_cherokeesidebar1")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_cherokeemarketplace"] = googletag.defineSlot("//116205717/CNI-Cherokeemarketplace", [300, 100], "js-dfp-tag-cni_cherokeemarketplace")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_cherokeeleaderboard"] = googletag.defineSlot("//116205717/CNI-Cherokeeleaderboard", [[728, 90], [320, 50]], "js-dfp-tag-cni_cherokeeleaderboard")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
googletag.cmd.push(function() {
      googletag.pubads().enableAsyncRendering();
        googletag.pubads().enableSingleRequest();
        googletag.pubads().collapseEmptyDivs();
      });
googletag.enableServices();
</script>
<link rel="shortcut icon" href="/sites/cherokeescout.etypegoogle7.com/files/cherokee-scout.jpg" type="image/jpeg" />
<link rel="revision" href="https://www.cherokeescout.com/sports/david-browns-ufc-rankings-xplainations-updated-22821" />
<script>window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};</script>

<title>David Brown’s UFC rankings with Xplainations updated for 2.28.21 | Cherokee Scout, Murphy, North Carolina</title>
<link rel="stylesheet" media="all" href="/sites/cherokeescout.etypegoogle7.com/files/css/css_KixTgo5r39dWURjfPDozJHDK1hz5DBUqqrDvPBfIB0I.css" />
<link rel="stylesheet" media="all" href="/sites/cherokeescout.etypegoogle7.com/files/css/css_NSFoFtYUzupWCFHSx3ycGXF65DCnO_8NlOEt4Bk860U.css" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Petrona" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Lato" />


<!--[if lte IE 8]>
<script src="/sites/cherokeescout.etypegoogle7.com/files/js/js_VtafjXmRvoUgAzqzYTA3Wrjkx9wcWhjP0G4ZnnqRamA.js"></script>
<![endif]-->
<script src="/sites/cherokeescout.etypegoogle7.com/files/js/js_P1NGcVaP41NJGJkUdicGZ5z4_V6DssyGg4AN_ryfFrE.js"></script>


</head>
<body class="path-node page-node-type-article cherokeescout">
<a href="#main-content" class="visually-hidden focusable skip-link">
    Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    
<div class="layout-container">
  <div class="container is-widescreen">
    
    <header role="banner" class="columns">
        <div class="region region-header-left column">
    <div id="block-tiemposcni-date" class="block block-etype block-date-block">
  
    
      
<p class="is-size-7">March 5, 2021</p>
<div><a role="button" class="navbar-burger is-hidden-desktop" aria-label="menu" aria-expanded="false"><i class="fas fa-bars"></i></a></div>
    
    <div role="search" class="block block-search container-inline">
  <form class="search-block-form" data-drupal-selector="search-block-form" action="/search/node" method="get"
        accept-charset="UTF-8" data-drupal-form-fields="search-edit-keys">
      <div class="search-edit-submit">
          <input class="fas fa-search js-form-submit form-submit" data-drupal-selector="search-edit-submit"
                 type="submit" value="Search" />
      </div>
      <input title="Enter the terms you wish to search for." data-drupal-selector="search-edit-keys" type="search"
             name="keys" value="" size="15" maxlength="128" class="form-search is-really-invisible">
  </form>
</div>
  </div>
<div id="block-extendedsearch" class="block block-block-content block-block-content1f331dfd-f65e-43f5-a346-170a9dba2899">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p><a class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif" href="https://cherokeescout.newsbank.com/">Extended Search</a></p>
</div>
      
  </div>

  </div>

        <div class="region region-header-center column">
    <div id="block-tiemposcni-branding" class="block block-system block-system-branding-block">
  
    
        <a href="/" title="Home" rel="home" class="site-logo">
      <img src="/sites/cherokeescout.etypegoogle7.com/files/cherokee_scout_web_header_0.jpg" alt="Cherokee Scout, Murphy, North Carolina Home" />
    </a>
  </div>

  </div>

        <div class="region region-header-right column">
      
        <div class="user-menu navbar-menu is-active is-shadowless is-hidden-touch">
          <a href="https://etypeservices.com/ReadTheEdition.aspx?Username=Ronnie5771&amp;Pub=3364&amp;PType=CHEro3364eekOUT600" target="_blank" id="etype_login_cni_e_edition" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">E-edition</a>
          <a href="https://www.etypeservices.com/Subscriber/SignIn.aspx?IssueID=213153&amp;ReturnUrl=https%3A//www.etypeservices.com/Subscriber/ReSubscribe.aspx%3FPubID%3D3364" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">Renew</a>
          <a href="/etype-login" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif" data-drupal-link-system-path="etype-login">Log In</a>
          <a href="/user/login" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif" data-drupal-link-system-path="user/login">Log in</a>
          <a href="https://etypeservices.com/Cherokee%20ScoutID600/default.aspx?PubID=3364" target="_blank" id="etype_login_cni_subscribe" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">Subscribe</a>
        </div>
  





  </div>

    </header>

    
      <div class="region region-navigation columns">
      <nav role="navigation" id="main-nav" aria-label="user navigation" class="column">
    <div class="navbar">
                <div class="navbar-start is-really-invisible columns">
            <div class="column">
                                <a role="button" class="navbar-burger is-active" aria-label="menu" aria-expanded="false"><i class="fas fa-times"></i></a>
                                <div role="search" class="block block-search container-inline">
  <form class="search-block-form" data-drupal-selector="search-block-form" action="/search/node" method="get"
        accept-charset="UTF-8" data-drupal-form-fields="search-edit-keys">
      <div class="search-edit-submit">
          <input class="fas fa-search js-form-submit form-submit" data-drupal-selector="search-edit-submit"
                 type="submit" value="Search" />
      </div>
      <input title="Enter the terms you wish to search for." data-drupal-selector="search-edit-keys" type="search"
             name="keys" value="" size="15" maxlength="128" class="form-search is-really-invisible">
  </form>
</div>
                <div id="mobile-nav">
                                                                <a href="/" class="navbar-item" data-drupal-link-system-path="&lt;front&gt;">Home</a>
                                                                    <a href="https://etypeservices.com/Cherokee%20ScoutID600/" class="navbar-item">E-Edition</a>
                                                                                                        <a href="/magazines" class="navbar-item" data-drupal-link-system-path="magazines">Magazines</a>
                                            
                                                                    <a href="/local" class="navbar-item" data-drupal-link-system-path="taxonomy/term/84">Local</a>
                                                                                                        <a href="/news" class="navbar-item" data-drupal-link-system-path="taxonomy/term/1">News</a>
                                                    <a href="/opinion" class="navbar-item" data-drupal-link-system-path="taxonomy/term/3">Opinion</a>
                                                    <a href="/cherokee-county-restaurants" class="navbar-item" data-drupal-link-system-path="node/1713">Cherokee County Restaurants</a>
                                            
                                                                    <a href="/regional" class="navbar-item" data-drupal-link-system-path="taxonomy/term/83">Regional</a>
                                                                    <a href="/sports" class="navbar-item" data-drupal-link-system-path="taxonomy/term/2">Sports</a>
                                                                    <a href="/obituaries" class="navbar-item" data-drupal-link-system-path="taxonomy/term/4">Obituaries</a>
                                                                    <a href="/events" class="navbar-item" data-drupal-link-system-path="taxonomy/term/85">Events</a>
                                                                    <a href="/nie" class="navbar-item" data-drupal-link-system-path="node/1717">NIE</a>
                                                                    <a href="/classified" class="navbar-item" data-drupal-link-system-path="classified">Classified</a>
                                                                                                        <a href="https://classadz.vdata.com/CommunityNewspapersMurphy/Advertising/Advertiser" class="navbar-item">Place a classified</a>
                                            
                                                                    <a href="/classified/legals" class="navbar-item" data-drupal-link-system-path="taxonomy/term/5">Legals</a>
                                                                    <a href="/contact" class="navbar-item" data-drupal-link-system-path="contact">Contact</a>
                                                                                                        <a href="/contact" class="navbar-item" data-drupal-link-system-path="contact">Contact</a>
                                                    <a href="/about" class="navbar-item" data-drupal-link-system-path="node/969">About Us</a>
                                                    <a href="/archives" class="navbar-item" data-drupal-link-system-path="node/973">Archive</a>
                                                    <a href="/webforms" class="navbar-item" data-drupal-link-system-path="webforms">Webforms</a>
                                            
                                                                    <a href="/advertise" class="navbar-item" data-drupal-link-system-path="node/971">Advertise</a>
                                                                    <a href="https://www.etypeservices.com/Cherokee%20ScoutID600/default.aspx?PubID=3364" class="navbar-item">Subscribe</a>
                                                                                </div>
            </div>
            <div class="column">  
        <div class="user-menu navbar-menu is-active is-shadowless is-hidden-touch">
          <a href="https://etypeservices.com/ReadTheEdition.aspx?Username=Ronnie5771&amp;Pub=3364&amp;PType=CHEro3364eekOUT600" target="_blank" id="etype_login_cni_e_edition" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">E-edition</a>
          <a href="https://www.etypeservices.com/Subscriber/SignIn.aspx?IssueID=213153&amp;ReturnUrl=https%3A//www.etypeservices.com/Subscriber/ReSubscribe.aspx%3FPubID%3D3364" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">Renew</a>
          <a href="/etype-login" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif" data-drupal-link-system-path="etype-login">Log In</a>
          <a href="/user/login" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif" data-drupal-link-system-path="user/login">Log in</a>
          <a href="https://etypeservices.com/Cherokee%20ScoutID600/default.aspx?PubID=3364" target="_blank" id="etype_login_cni_subscribe" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">Subscribe</a>
        </div>
  




</div>
        </div>
                <div id="main-navbar-menu" class="navbar-menu has-text-weight-semibold">
                                                                                                                                                                <a href="/" class="navbar-item" data-drupal-link-system-path="&lt;front&gt;">Home</a>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="https://etypeservices.com/Cherokee%20ScoutID600/" class="navbar-item">E-Edition</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="/magazines" class="navbar-item" data-drupal-link-system-path="magazines">Magazines</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="/local" class="navbar-item" data-drupal-link-system-path="taxonomy/term/84">Local</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="/news" class="navbar-item" data-drupal-link-system-path="taxonomy/term/1">News</a>
                                                                                                                                                            <a href="/opinion" class="navbar-item" data-drupal-link-system-path="taxonomy/term/3">Opinion</a>
                                                                                                                                                            <a href="/cherokee-county-restaurants" class="navbar-item" data-drupal-link-system-path="node/1713">Cherokee County Restaurants</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                            <a href="/regional" class="navbar-item" data-drupal-link-system-path="taxonomy/term/83">Regional</a>
                                                                                                                                                            <a href="/sports" class="navbar-item" data-drupal-link-system-path="taxonomy/term/2">Sports</a>
                                                                                                                                                            <a href="/obituaries" class="navbar-item" data-drupal-link-system-path="taxonomy/term/4">Obituaries</a>
                                                                                                                                                            <a href="/events" class="navbar-item" data-drupal-link-system-path="taxonomy/term/85">Events</a>
                                                                                                                                                            <a href="/nie" class="navbar-item" data-drupal-link-system-path="node/1717">NIE</a>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="/classified" class="navbar-item" data-drupal-link-system-path="classified">Classified</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="https://classadz.vdata.com/CommunityNewspapersMurphy/Advertising/Advertiser" class="navbar-item">Place a classified</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                            <a href="/classified/legals" class="navbar-item" data-drupal-link-system-path="taxonomy/term/5">Legals</a>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="/contact" class="navbar-item" data-drupal-link-system-path="contact">Contact</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="/contact" class="navbar-item" data-drupal-link-system-path="contact">Contact</a>
                                                                                                                                                            <a href="/about" class="navbar-item" data-drupal-link-system-path="node/969">About Us</a>
                                                                                                                                                            <a href="/archives" class="navbar-item" data-drupal-link-system-path="node/973">Archive</a>
                                                                                                                                                            <a href="/webforms" class="navbar-item" data-drupal-link-system-path="webforms">Webforms</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                            <a href="/advertise" class="navbar-item" data-drupal-link-system-path="node/971">Advertise</a>
                                                                                                                                                            <a href="https://www.etypeservices.com/Cherokee%20ScoutID600/default.aspx?PubID=3364" class="navbar-item">Subscribe</a>
                                                                                                    
                    </div>
                <div class="navbar-end">
              <a href="https://www.facebook.com/Cherokee-Scout-183779271641767/" class="has-text-grey-dark" target="_blank" aria-label="Facebook"><i class="fab fa-facebook is-size-3"></i><span class="sr-only">facebook</span></a><a href="https://twitter.com/theScoutnews" class="has-text-grey-dark" target="_blank" aria-label="Twitter"><i class="fab fa-twitter is-size-3"></i><span class="sr-only">twitter</span></a>

        </div>
    </div>
</nav>




  </div>

    
      <div class="region region-leaderboard">
    <div id="block-dfptagcnicherokeeleaderboard" class="block block-dfp block-dfp-adbe90987f-5921-42c2-af77-e76fb788a975">
  
    
      <div id="js-dfp-tag-cni_cherokeeleaderboard">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_cherokeeleaderboard');
        });
    </script>
</div>

  </div>

  </div>

      <div class="region region-top-content">
    <div data-drupal-messages-fallback class="hidden"></div>

  </div>


    <main role="main" class="columns">
      <a id="main-content" tabindex="-1"></a>      <div class="main-content-inner column">
                    <div class="region region-content">
    <div id="block-pagetitle" class="block block-core block-page-title-block">
  
    
      
  <h1 class="title"><span property="schema:name" class="field field--name-title field--type-string field--label-hidden">David Brown’s UFC rankings with Xplainations updated for 2.28.21</span>
</h1>


  </div>
<div id="block-tiemposcni-content" class="block block-system block-system-main-block">
  
    
      

<article data-history-node-id="10304" role="article" about="/sports/david-browns-ufc-rankings-xplainations-updated-22821" typeof="schema:Article" class="node node--type-article node--promoted node--view-mode-full sports">

  <div id="google_translate_element"></div>

  
      <span property="schema:name" content="David Brown’s UFC rankings with Xplainations updated for 2.28.21" class="rdf-meta hidden"></span>


      <footer class="node__meta">
      <article typeof="schema:Person" about="/user/82" class="profile">
  </article>

      <div class="node__submitted">
        <span id="author_id">By </span><span rel="schema:author" class="field field--name-uid field--type-entity-reference field--label-hidden"><a title="View user profile." href="/user/82" lang="" about="/user/82" typeof="schema:Person" property="schema:name" datatype="">David Brown</a></span>
 on Friday, March 5, 2021
          <span property="schema:dateCreated" content="2021-03-05T21:07:29+00:00" class="rdf-meta hidden"></span>

      </div>
    </footer>
  
  <div class="node__content">
                            
  <div class="field field--name-field-image field--type-image field--label-visually_hidden">
    <div class="field__label visually-hidden">Image</div>
          <div class="field__items">
                  </div>
      </div>

  <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-visually_hidden">
    <div class="field__label visually-hidden">Body</div>
              <div property="schema:text" class="field__item"><center>
<p><em>In deciding how to rank, I look at head-to-head matchups first, then fights over the last few years, giving more credence to recent ones. The level of competition is considered, and MMA math only plays a small part in the process.</em></p>

<hr />
<p>MEN’S POUND-FOR-POUND</p>

<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td> 
			<p>dB rankings</p>

			<p>1. Khabib Nurmagomedov (C)</p>

			<p>2. Jon Jones</p>

			<p>3. Israel Adesanya (C)</p>

			<p>4. Kamaru Usman (C)</p>

			<p>5. Stipe Miocic (C)</p>

			<p>6. Alexander Volkanovski (C)</p>

			<p>7. Deiveson Figueiredo (C)</p>

			<p>8. Petr Yan (C)</p>

			<p>9. Jan Blachowicz (C)</p>

			<p>10. Robert Whittaker</p>

			<p>11. Dustin Poirier</p>

			<p>12. Max Holloway</p>

			<p>13. Francis Ngannou</p>

			<p>14. Justin Gaethje</p>

			<p>15. Colby Covington</p>
			</td>
			<td> 
			<p>UFC rankings</p>

			<p>1. Khabib Nurmagomedov (C)</p>

			<p>2. Jon Jones</p>

			<p>3. Israel Adesanya (C)</p>

			<p>4. Stipe Miocic (C)</p>

			<p>5. Kamaru Usman (C)</p>

			<p>6. Alexander Volkanovski (C)</p>

			<p>7. Dustin Poirier</p>

			<p>8. Max Holloway</p>

			<p>9. Deiveson Figueiredo (C)</p>

			<p>10. Petr Yan (C)</p>

			<p>11. Justin Gaethje</p>

			<p>12. Robert Whittaker</p>

			<p>13. Francis Ngannou</p>

			<p>14. Jan Blachowicz (C)</p>

			<p>15. Conor McGregor -3</p>
			</td>
		</tr>
	</tbody>
</table>
<br />
X: Poirier moves up based on being the uncrowned LW champion after kicking McGregor’s legs numb before the KO; the trilogy can’t be far away.
<hr /></center>

<center>FLYWEIGHT</center>

<center>
<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td> 
			<p>dB rankings</p>

			<p>Champion: DEIVESON FIGUEIREDO</p>

			<p>1. Brandon Moreno</p>

			<p>2. Askar Askarov</p>

			<p>3. Joseph Benavidez</p>

			<p>4. Alex Perez</p>

			<p>5. Alexandre Pantoja +1</p>

			<p>6. Brandon Royval -1</p>

			<p>7. Manel Kape *</p>

			<p>8. Matt Schnell</p>

			<p>9. Kai Kara France -2</p>

			<p>10. Rogerio Bontorin -1</p>

			<p>11. David Dvorak -1</p>

			<p>12. Tim Elliott -1</p>

			<p>13. Raulian Paiva -1</p>

			<p>14. Amir Albazi *</p>

			<p>15. Su Mudaerji *</p>
			</td>
			<td> 
			<p>UFC rankings</p>

			<p>Champion: DEIVESON FIGUEIREDO</p>

			<p>1. Brandon Moreno</p>

			<p>2. Joseph Benavidez</p>

			<p>3. Askar Askarov</p>

			<p>4. Alex Perez</p>

			<p>5. Alexandre Pantoja</p>

			<p>6. Brandon Royval</p>

			<p>7. Matt Schnell</p>

			<p>8. Kai Kara France</p>

			<p>9. Rogerio Bontorin</p>

			<p>10. David Dvorak</p>

			<p>11. Raulian Paiva</p>

			<p>12. Tim Elliott</p>

			<p>13. Amir Albazi</p>

			<p>14. Su Mudaerji</p>

			<p>15. Tyson Nam</p>
			</td>
		</tr>
	</tbody>
</table>
</center>

<center> </center>

<center>
<p>Out of the rankings: Zhalgas Zhumagulov, Tyson Nam, Tagir Ulanbekov</p>

<p>X: Three new faces are in as UFC continues rebuilding the FLW division with new talent. I might have Kape too high after his UFC debut, but he gave Pantoja all he could handle.</p>

<hr />
<p>BANTAMWEIGHT</p>

<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td style="width: 162px;"> 
			<p>dB rankings</p>

			<p>Champion: PETR YAN</p>

			<p>1. Aljamain Sterling</p>

			<p>2. Cory Sandhagen</p>

			<p>3. Rob Font +2</p>

			<p>4. Marlon Moraes +2</p>

			<p>5. Jose Aldo -2</p>

			<p>6. Frankie Edgar -2</p>

			<p>7. Pedro Munhoz</p>

			<p>8. Cody Garbrandt</p>

			<p>9. Jimmie Rivera</p>

			<p>10. Cody Stamann</p>

			<p>11. Raphael Assuncao</p>

			<p>12. Ricky Simon *</p>

			<p>13. Merab Dvalishvili</p>

			<p>14. Song Yadong</p>

			<p>15. Marlon Vera</p>
			</td>
			<td style="width: 140px;"> 
			<p>UFC rankings</p>

			<p>Champion: PETR YAN</p>

			<p>1. Aljamain Sterling</p>

			<p>2. Cory Sandhagen</p>

			<p>3. Rob Font</p>

			<p>4. Cody Garbrandt</p>

			<p>5. Jose Aldo</p>

			<p>6. Marlon Moraes</p>

			<p>7. Frankie Edgar</p>

			<p>8. Pedro Munhoz</p>

			<p>9. Raphael Assuncao</p>

			<p>10. Jimmie Rivera</p>

			<p>11. Dominick Cruz</p>

			<p>12. Merab Dvalishvili</p>

			<p>13. Cody Stamann</p>

			<p>14. Song Yadong</p>

			<p>15. Marlon Vera</p>
			</td>
		</tr>
	</tbody>
</table>

<p>Out of the rankings: Casey Kenney</p>

<p>Closing in on rankings: Raoni Barcelos</p>

<p>Note: T.J. Dillashaw is still not eligible to be ranked coming off suspension.</p>

<p>X: Simon makes a big jump, but he looked great against Kelleher and already has a win over Dvalishvili.</p>

<hr /></center>

<center>FEATHERWEIGHT</center>

<center>
<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td> 
			<p>dB rankings</p>

			<p>Champion: ALEXANDER VOLKANOVSKI</p>

			<p>1. Max Holloway</p>

			<p>2. Brian Ortega</p>

			<p>3. Zabit Magomedsharipov</p>

			<p>4. Yair Rodriguez</p>

			<p>5. Chan Sung Jung</p>

			<p>6. Calvin Kattar</p>

			<p>7. Arnold Allen</p>

			<p>8. Jeremy Stephens</p>

			<p>9. Josh Emmett</p>

			<p>10. Shane Burgos</p>

			<p>11. Sodiq Yusuff</p>

			<p>12. Dan Inge</p>

			<p>13. Edson Barboza</p>

			<p>14. Bryce Mitchell</p>

			<p>15. Movsar Evloev *</p>
			</td>
			<td> 
			<p>UFC rankings</p>

			<p>Champion: ALEXANDER VOLKANOVSKI</p>

			<p>1. Max Holloway</p>

			<p>2. Brian Ortega</p>

			<p>3. Zabit Magomedsharipov</p>

			<p>4. Yair Rodriguez</p>

			<p>5. Chan Sung Jung</p>

			<p>6. Calvin Kattar</p>

			<p>7. Josh Emmett</p>

			<p>8. Jeremy Stephens</p>

			<p>9. Dan Ige</p>

			<p>10. Sodiq Yusuff</p>

			<p>11. Arnold Allen</p>

			<p>12. Shane Burgos</p>

			<p>13. Bryce Mitchell</p>

			<p>14. Edson Barboza</p>

			<p>15. Movsar Evloev</p>
			</td>
		</tr>
	</tbody>
</table>
</center>

<center>
<p>Out of the rankings: Ryan Hall</p>

<p>Closing in on rankings: Giga Chikadze</p>

<p>X: Evloev earn the nod over Hall by staying unbeaten while the other stays inactive.</p>

<hr />
<p>LIGHTWEIGHT</p>

<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td> 
			<p>dB rankings</p>

			<p>Champion: KHABIB NURMAGOMEDOV</p>

			<p>1. Dustin Poirier</p>

			<p>2. Justin Gaethje</p>

			<p>3. Charles Oliveira</p>

			<p>4. Tony Ferguson</p>

			<p>5. Michael Chandler +5</p>

			<p>6. Rafael dos Anjos</p>

			<p>7. Conor McGregor +2</p>

			<p>8. Beneil Dariush +5</p>

			<p>9. Diego Ferreira -1</p>

			<p>10. Dan Hooker -5</p>

			<p>11. Paul Felder -4</p>

			<p>12. Al Iaquinta -1</p>

			<p>13. Kevin Lee -1</p>

			<p>14. Drew Dober</p>

			<p>15. Islam Makhachev</p>
			</td>
			<td> 
			<p>UFC rankings</p>

			<p>Champion: KHABIB NURMAGOMEDOV</p>

			<p>1. Dustin Poirier</p>

			<p>2. Justin Gaethje</p>

			<p>3. Charles Oliveira</p>

			<p>4. Michael Chandler</p>

			<p>5. Tony Ferguson</p>

			<p>6. Conor McGregor</p>

			<p>7. Rafael dos Anjos</p>

			<p>8. Dan Hooker</p>

			<p>9. Beneil Dariush</p>

			<p>10. Paul Felder</p>

			<p>11. Kevin Lee</p>

			<p>12. Diego Ferreira</p>

			<p>13. Al Iaquinta</p>

			<p>14. Islam Makhachev</p>

			<p>15. Gregor Gillespie</p>
			</td>
		</tr>
	</tbody>
</table>
</center>

<center>
<p>Closing in on rankings: Leonardo Santos, Rafael Fiziev</p>

<p>X: Dariush deservedly re-enters the top 10 years after his first appearance with a second win over Ferreira, while Chandler’s rise pushes hooker and Felder back. Why UFC has Lee ranked two spots higher than Iaquinta – who beat him twice, and both have been inactive – is a mystery.</p>

<hr />
<p>WELTERWEIGHT</p>

<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td> 
			<p>dB rankings</p>

			<p>Champion: KAMARU USMAN</p>

			<p>1. Colby Covington</p>

			<p>2. Gilbert Burns</p>

			<p>3. Leon Edwards</p>

			<p>4. Tyron Woodley</p>

			<p>5. Stephen Thompson</p>

			<p>6. Demian Maia</p>

			<p>7. Jorge Masvidal</p>

			<p>8. Michael Chiesa</p>

			<p>9. Vicente Luque</p>

			<p>10. Geoff Neal +1</p>

			<p>11. Neil Magny -1</p>

			<p>12. Li Jingliang *</p>

			<p>13. Belal Muhammad</p>

			<p>14. James Krause</p>

			<p>15. Santiago Ponzinibbio *</p>
			</td>
			<td> 
			<p>UFC rankings</p>

			<p>Champion: KAMARU USMAN</p>

			<p>1. Colby Covington</p>

			<p>2. Gilbert Burns</p>

			<p>3. Leon Edwards</p>

			<p>4. Jorge Masvidal</p>

			<p>5. Stephen Thompson</p>

			<p>6. Michael Chiesa</p>

			<p>7. Tyron Woodley</p>

			<p>8. Demian Maia</p>

			<p>9. Neil Magny</p>

			<p>10. Vicente Luque</p>

			<p>11. Geoff Neal</p>

			<p>12. Li Jingliang</p>

			<p>13. Belal Muhammad</p>

			<p>14. Khamzat Chimaev</p>

			<p>15. Robbie Lawler</p>
			</td>
		</tr>
	</tbody>
</table>

<p>Out of the rankings: Anthony Pettis (signed with PFL)</p>

<p>Closing in on rankings: Sean Brady, Miguel Baeza </p>

<p>X: Ponzinibbio barely re-enters the rankings after two years off and a loss, but his seven-fight win streak before that keeps him hanging. Meanwhile, Li re-enters the top 15 with momentum.</p>

<hr /></center>

<center>MIDDLEWEIGHT</center>

<center>
<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td> 
			<p>dB rankings</p>

			<p>Champion: ISRAEL ADESANYA</p>

			<p>1. Robert Whittaker</p>

			<p>2. Paulo Costa</p>

			<p>3. Jared Cannonier</p>

			<p>4. Marvin Vettori</p>

			<p>5. Jack Hermansson</p>

			<p>6. Darren Till</p>

			<p>7. Kelvin Gastelum</p>

			<p>8. Derek Brunson</p>

			<p>9. Uriah Hall</p>

			<p>10. Kevin Holland</p>

			<p>11. Jacare Souza</p>

			<p>12. Chris Weidman</p>

			<p>13. Omari Akhmedov</p>

			<p>14, Edmen Shahbazyan</p>

			<p>15. Brad Tavares *</p>
			</td>
			<td> 
			<p>UFC rankings</p>

			<p>Champion: ISRAEL ADESANYA</p>

			<p>1. Robert Whittaker</p>

			<p>2. Paulo Costa</p>

			<p>3. Jared Cannonier</p>

			<p>4. Darren Till</p>

			<p>5. Marvin Vettori</p>

			<p>6. Jack Hermansson</p>

			<p>7. Derek Brunson</p>

			<p>8. Kelvin Gastelum</p>

			<p>9. Uriah Hall</p>

			<p>10. Kevin Holland</p>

			<p>11. Chris Weidman</p>

			<p>12, Edmen Shahbazyan</p>

			<p>13. Omari Akhmedov</p>

			<p>14. Brad Taveras</p>

			<p>15. Sean Strickland</p>
			</td>
		</tr>
	</tbody>
</table>
</center>

<center>Out of the rankings: Ian Heinisch</center>

<center>
<p>X: Tavares re-enters the top 15 with a win Heinisch’s loss to Gastelum, who I admittedly might have ranked too high, but Brunson, Hall and/or Holland are poised to jump ahead with anther W.</p>
</center>

<center>
<hr /></center>

<center>LIGHT HEAVYWEIGHT</center>

<center>
<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td> 
			<p>dB rankings</p>

			<p>Champion: JAN BLACHOWICZ</p>

			<p>1. Glover Teixeira</p>

			<p>2. Thiago Santos</p>

			<p>3. Dominick Reyes</p>

			<p>4. Jiri Prochazka</p>

			<p>5. Aleksandar Rakic</p>

			<p>6. Magomed Ankalaev +4</p>

			<p>7. Anthony Smith -1</p>

			<p>8. Volkan Oezdemir -1</p>

			<p>9. Nikita Krylov -1</p>

			<p>10. Johnny Walker -1</p>

			<p>11. Misha Cirkunov</p>

			<p>12. Jimmy Crute</p>

			<p>13. Ryan Spann</p>

			<p>14. Paul Craig</p>

			<p>15. Jamahal Hill</p>
			</td>
			<td> 
			<p>UFC rankings</p>

			<p>Champion: JAN BLACHOWICZ</p>

			<p>1. Glover Teixeira</p>

			<p>2. Thiago Santos</p>

			<p>3. Dominick Reyes</p>

			<p>4. Aleksandar Rakic</p>

			<p>5. Jiri Prochazka</p>

			<p>6. Anthony Smith</p>

			<p>7. Magomed Ankalaev</p>

			<p>8. Volkan Oezdemir</p>

			<p>9. Nikita Krylov</p>

			<p>10. Johnny Walker</p>

			<p>11. Misha Cirkunov</p>

			<p>12. Jimmy Crute</p>

			<p>13. Ryan Spann</p>

			<p>14. Paul Craig</p>

			<p>15. Jamahal Hill</p>
			</td>
		</tr>
	</tbody>
</table>
 

<hr /></center>

<center>HEAVYWEIGHT</center>

<center> </center>

<center>
<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td> 
			<p>dB rankings</p>

			<p>Champion: STIPE MIOCIC</p>

			<p>1. Francis Ngannou</p>

			<p>2. Derrick Lewis +2</p>

			<p>3. Curtis Blaydes -1</p>

			<p>4. Jairzinho Rozenstruik</p>

			<p>5. Alexander Volkov +1</p>

			<p>6. Alistair Overeem -1 **</p>

			<p>7. Ciryl Gane</p>

			<p>8. Augusto Sakai</p>

			<p>9. Shamil Abdurakhimov</p>

			<p>10. Walt Harris</p>

			<p>11. Marcin Tybura +1</p>

			<p>12. Sergei Pavlovich +1</p>

			<p>13. Junior dos Santos +1 **</p>

			<p>14. Chris Daukaus *</p>

			<p>15. Tom Aspinall *</p>
			</td>
			<td> 
			<p>UFC rankings</p>

			<p>Champion: STIPE MIOCIC</p>

			<p>1. Francis Ngannou</p>

			<p>2. Derrick Lewis</p>

			<p>3. Curtis Blaydes</p>

			<p>4. Ciryl Gane</p>

			<p>5. Alexander Volkov</p>

			<p>6. Jairzinho Rozenstruik</p>

			<p>7. Alistair Overeem</p>

			<p>8. Shamil Abdurakhimov</p>

			<p>9. Augusto Sakai</p>

			<p>10. Chris Daukaus</p>

			<p>11. Walt Harris</p>

			<p>12. Junior dos Santos</p>

			<p>13. Sergei Pavlovich</p>

			<p>14. Blagoy Ivanov</p>

			<p>15. Marcin Tybyra</p>
			</td>
		</tr>
	</tbody>
</table>
<br />
X: You could justify ranking “The Black Beast” No. 1 since he has a win over Ngannou, but that was hardly impressive and you can’t overlook the way Ngannou has thrashed his competition since then. Gane was solid but unspectacular in bearing the listless Rozenstruik. Daukaus kicks Oleinik out of the rankings, while Aspinall cuts short Arlovski’s latest rebirth.
<hr /></center>

<center>WOMEN’S POUND-FOR-POUND</center>

<center>
<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td> 
			<p>dB rankings</p>

			<p>1. Amanda Nunes</p>

			<p>2. Valentina Shevchenko</p>

			<p>3. Weili Zhang</p>

			<p>4. Rose Namajunas</p>

			<p>5. Joanna Jedrzejczyk</p>

			<p>6. Jessica Andrade</p>

			<p>7. Germaine De Randamie</p>

			<p>8. Holly Holm</p>

			<p>9. Aspen Ladd</p>

			<p>10. Katlyn Chookagian</p>

			<p>11. Jennifer Maia</p>

			<p>12. Lauren Murphy</p>

			<p>13. Cynthia Calvillo</p>

			<p>14. Yan Xiaonan</p>

			<p>15. Yana Kunitskaya *</p>
			</td>
			<td> 
			<p>UFC rankings</p>

			<p>1. Amanda Nunes</p>

			<p>2. Valentina Shevchenko</p>

			<p>3. Weili Zhang</p>

			<p>4. Rose Namajunas</p>

			<p>5. Jessica Andrade</p>

			<p>6. Joanna Jedrzejczyk</p>

			<p>7. Germaine De Randamie</p>

			<p>8. Holly Holm</p>

			<p>9. Aspen Ladd</p>

			<p>10. Katlyn Chookagian</p>

			<p>11. Nina Ansaroff</p>

			<p>12. Xiaonan Yan</p>

			<p>13. Carla Esparza</p>

			<p>14. Cynthia Calvillo</p>

			<p>15. Claudia Gadelha</p>
			</td>
		</tr>
	</tbody>
</table>
<br />
Out of the rankings: Joanne Calderwood</center>

<center>
<p>X: Kunitskaya doesn’t look spectacular in the cage, but you can’t argue with her results, as the former Invicta title holder is 4-1 at BW in the UFC.</p>
</center>

<center>
<hr /></center>

<center>WOMEN’S STRAWWEIGHT</center>

<center>
<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td> 
			<p>dB rankings</p>

			<p>Champion: WEILI ZHANG</p>

			<p>1. Rose Namajunas</p>

			<p>2. Joanna Jedrzejczyk</p>

			<p>3. Xiaonan Yan</p>

			<p>4. Nina Ansaroff</p>

			<p>5. Claudia Gadelha</p>

			<p>6. Carla Esparza</p>

			<p>7. Marina Rodriguez</p>

			<p>8. Michelle Waterson</p>

			<p>9. Amanda Ribas</p>

			<p>10. Mackenzie Dern</p>

			<p>11. Tecia Torres</p>

			<p>12. Virna Jandiroba</p>

			<p>13. Angela Hill</p>

			<p>14. Brianna Van Buren</p>

			<p>15. Livinha Souza</p>
			</td>
			<td> 
			<p>UFC rankings</p>

			<p>Champion: WEILI ZHANG</p>

			<p>1. Rose Namajunas</p>

			<p>2. Joanna Jedrzejczyk</p>

			<p>3. Yan Xiaonan</p>

			<p>4. Carla Esparza</p>

			<p>5. Nina Ansaroff</p>

			<p>6. Claudia Gadelha</p>

			<p>7. Michelle Waterson</p>

			<p>8. Marina Rodriguez</p>

			<p>9. Tecia Torres</p>

			<p>9. Amanda Ribas</p>

			<p>11. Mackenzie Dern</p>

			<p>12. Angela Hill</p>

			<p>13. Virna Jandiroba</p>

			<p>14. Felice Herrig</p>

			<p>15. Livinha Souza</p>
			</td>
		</tr>
	</tbody>
</table>
<br />
X: No changes this month.
<hr /></center>

<center>WOMEN’S FLYWEIGHT</center>

<center>
<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td> 
			<p>dB rankings</p>

			<p>Champion: VALENTINA SHEVCHENKO</p>

			<p>1. Jessica Andrade</p>

			<p>2. Katlyn Chookagian</p>

			<p>3. Jennifer Maia</p>

			<p>4. Lauren Murphy</p>

			<p>5. Cynthia Calvillo</p>

			<p>6. Joanne Calderwood</p>

			<p>7. Jessica Eye</p>

			<p>8. Viviane Araujo</p>

			<p>9. Roxanne Modafferi</p>

			<p>10. Alexa Grasso +5</p>

			<p>11. Antonina Shevchenko</p>

			<p>12. Alexis Davis * **</p>

			<p>13. Andrea Lee -3</p>

			<p>14. Talia Santos</p>

			<p>15. Maycee Barber -2</p>
			</td>
			<td> 
			<p>UFC rankings</p>

			<p>Champion: VALENTINA SHEVCHENKO</p>

			<p>1. Jessica Andrade</p>

			<p>2. Katlyn Chookagian</p>

			<p>3. Lauren Murphy</p>

			<p>4. Jennifer Maia</p>

			<p>5. Cynthia Calvillo</p>

			<p>6. Joanne Calderwood</p>

			<p>7. Viviane Araujo</p>

			<p>8. Jessica Eye</p>

			<p>9. Roxanne Modafferi</p>

			<p>10. Alexa Grasso</p>

			<p>11. Alexis Davis</p>

			<p>12. Andrea Lee</p>

			<p>13. Antonina Shevchenko</p>

			<p>14. Talia Santos</p>

			<p>15. Maycee Barber</p>
			</td>
		</tr>
	</tbody>
</table>

<p>Out of the rankings: Montana De La Rosa</p>

<p>Closing in on rankings: Miranda Maverick</p>

<p>X: Grasso continues marching up the FLW rankings, this time at Barber’s expense, while Davis returns.</p>

<hr /></center>

<center>WOMEN’S BANTAMWEIGHT</center>

<center>
<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td> 
			<p>dB rankings</p>

			<p>Champion: AMANDA NUNES</p>

			<p>1. Germaine de Randamie</p>

			<p>2. Holly Holm</p>

			<p>3. Aspen Ladd</p>

			<p>4. Irene Aldana +1</p>

			<p>5. Yana Kunitskaya +2</p>

			<p>6. Ketlen Vieira</p>

			<p>7. Julianna Pena +1</p>

			<p>8. Marion Reneau +1</p>

			<p>9. Sara McMann +1</p>

			<p>10. Lina Lansberg +1</p>

			<p>11. Macy Chiasson +1</p>

			<p>12. Pannie Kianzad +1</p>

			<p>13. Karol Rosa *</p>

			<p>14. Sijara Eubanks</p>

			<p>15. Julia Avila</p>
			</td>
			<td> 
			<p>UFC rankings</p>

			<p>Champion: AMANDA NUNES</p>

			<p>1. Germaine de Randamie</p>

			<p>2. Holly Holm</p>

			<p>3. Aspen Ladd</p>

			<p>4. Irene Aldana</p>

			<p>5. Yana Kunitskaya</p>

			<p>6. Julianna Pena</p>

			<p>7. Ketlen Vieira</p>

			<p>8. Sara McMann</p>

			<p>9. Marion Reneau</p>

			<p>10. Macy Chiasson</p>

			<p>11. Lina Lansberg</p>

			<p>12. Pannie Kianzad</p>

			<p>13. Sijara Eubanks</p>

			<p>14. Karol Rosa</p>

			<p>15. Julia Avila</p>
			</td>
		</tr>
	</tbody>
</table>

<p>Out of the rankings: Raquel Pennington (suspension)</p>

<p>Closing in on rankings: Tracy Cortez</p>

<p>X: Kunitskaya leapfrogs into the top 5 with her hard-nosed victory over Vieira. The fact that Aldana KO’d Vieira keeps her a notch above Kunitskaya in the rankings.</p>

<hr /></center>

<center>WOMEN’S FEATHERWEIGHT</center>

<center> </center>

<center>
<table align="center" border="0" cellpadding="1" cellspacing="1">
	<tbody>
		<tr>
			<td>
			<p>Champion: AMANDA NUNES</p>

			<p>No divisional rankings.</p>
			</td>
			<td> </td>
		</tr>
	</tbody>
</table>

<hr />
<p><b>IMPORTANT UPCOMING FIGHTS FOR RANKINGS</b></p>

<p> </p>

<p>March 6 – UFC 259</p>

<p>Jan Blachowicz vs.Israel Adesanya for LHW title</p>

<p>Amanda Nunes vs. Megan Anderson for FW title</p>

<p>Petr Yan vs. Aljamain Sterling for BW title</p>

<p>Islam Makhachev vs. Drew Dober</p>

<p>Thiago Santos vs. Aleksandar Rakic</p>

<p> </p>

<p>March 13 – UFC Fight Night 187</p>

<p>Leon Edwards vs. Belal Muhammad</p>

<p> </p>

<p>March 20 – UFC on ESPN 21</p>

<p>Derek Brunson vs. Kevin Holland</p>

<p>Paul Craig vs. Jamahal Hill</p>

<p>Marion Reneau vs. Macy Chiasson</p>

<p> </p>

<p>March 27 – UFC 260</p>

<p>Stipe Miocic vs. Francis Ngannou for HW title</p>

<p>Alexander Volkanovski vs. Brian Ortega for FW title</p>

<p>Anthony Smith vs. Jimmy Crute</p>

<p>Tyron Woodley vs. Vincente Luque</p>

<p> </p>

<p>The updated March rankings will be posted after UFC 260. Until then, enjoy the fights.</p>
</center>

<center>For comments, questions and suggestions, email dbrown@cherokeescout.com or contact him on Twitter @daviddbstroh.</center>

<center> </center>
</div>
          </div>
<span class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.cherokeescout.com/sports/david-browns-ufc-rankings-xplainations-updated-22821" data-a2a-title="David Brown’s UFC rankings with Xplainations updated for 2.28.21"><a class="a2a_button_facebook"></a><a class="a2a_button_twitter"></a><a class="a2a_button_print"></a></span>
                    </div>
</article>

  </div>

  </div>

        
        
              </div>

                <aside class="region region-sidebar column layout-sidebar"  role="complementary">
    <div id="block-dfptagcnicherokeemarketplace" class="block block-dfp block-dfp-adb8f6c72b-e965-449f-9505-56bdc7d13cc7">
  
    
      <div id="js-dfp-tag-cni_cherokeemarketplace">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_cherokeemarketplace');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnicherokeesidebar1" class="block block-dfp block-dfp-adff8228e6-96dc-4bf3-9c99-9daf118c6bfb">
  
    
      <div id="js-dfp-tag-cni_cherokeesidebar1">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_cherokeesidebar1');
        });
    </script>
</div>

  </div>
<div id="block-tiemposcni-etypeeedition" class="block block-etype block-etype-block">
  
    
      <div class="e-edition"><div><a href="https://etypeservices.com/Cherokee%20ScoutID600" target="_blank" aria-label="Cherokee Scout, Murphy, North Carolina e-Edition"><img src="https://etypeservices.com/LandingPageImages/Cherokee%20Scout/currentpg1.jpg" alt="Cherokee Scout, Murphy, North Carolina e-Edition"></a></div>
<p><a href="https://etypeservices.com/Cherokee%20ScoutID600" target="_blank" aria-label="Cherokee Scout, Murphy, North Carolina e-Edition">Read Cherokee Scout, Murphy, North Carolina</a></p></div>

  </div>
<div id="block-dfptagcnicherokeesidebar2" class="block block-dfp block-dfp-ad09f4561f-033a-42e2-8ace-69d342aad735">
  
    
      <div id="js-dfp-tag-cni_cherokeesidebar2">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_cherokeesidebar2');
        });
    </script>
</div>

  </div>
<div id="block-weatherwidget-2" class="block block-etype block-weatherwidget-block weatherwidget">
      <iframe style="display: block;" src="https://cdnres.willyweather.com/widget/loadView.html?id=114336" frameborder="0" scrolling="no" title="Weather Widget"></iframe>
  </div>
<div id="block-dfptagcnicherokeesidebarnetwork1" class="block block-dfp block-dfp-ad3baf6be1-a98c-4f54-8c1d-73a50f9bb769">
  
    
      <div id="js-dfp-tag-cni_cherokeesidebarnetwork1">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_cherokeesidebarnetwork1');
        });
    </script>
</div>

  </div>
<div id="block-tiemposcni-popularcontent" role="navigation" class="block block-statistics block-statistics-popular-block">
  
      <h3 class="section-tag-heading">Popular content</h3>
    
      <div class="item-list"><h3>Today's:</h3><ul><li><a href="/local-news/pastor-faces-sex-charge" hreflang="en">Pastor faces sex charge</a></li><li><a href="/opinion/be-careful-when-taking-out-trash" hreflang="en">Be careful when taking out the trash</a></li><li><a href="/local-news-newsletter/covid-19-update" hreflang="en">COVID-19 Update</a></li></ul></div><br /><div class="item-list"><h3>All time:</h3><ul><li><a href="/local-news-newsletter/covid-19-update" hreflang="en">COVID-19 Update</a></li><li><a href="/local-news/6-locals-arrested-drug-charges" hreflang="en">6 locals arrested on drug charges</a></li><li><a href="/more-residents-test-positive" hreflang="en">More residents test positive</a></li></ul></div><br /><div class="item-list"><h3>Last viewed:</h3><ul><li><a href="/sports/david-browns-ufc-rankings-xplainations-updated-22821" hreflang="en">David Brown’s UFC rankings with Xplainations updated for 2.28.21</a></li><li><a href="/obituaries/jane-swan" hreflang="en">Jane Swan</a></li><li><a href="/obituaries/father-george-kloster-jr" hreflang="en">Father George Kloster Jr.</a></li></ul></div><br />
  </div>
<div id="block-dfptagcnicherokeesidebar3" class="block block-dfp block-dfp-ad3005786e-b390-47cd-ac33-16306f06938c">
  
    
      <div id="js-dfp-tag-cni_cherokeesidebar3">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_cherokeesidebar3');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnicherokeepromo" class="block block-dfp block-dfp-ad742c3a1e-914e-4347-8dec-66fbced2fbad">
  
    
      <div id="js-dfp-tag-cni_cherokeepromo">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_cherokeepromo');
        });
    </script>
</div>

  </div>
<div id="block-npcamarketplace" class="block block-block-content block-block-content6ac8e399-37ee-4672-a8ca-c6d3c8a11482">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><script type="text/javascript">
google_ad_client = "ca-pub-6055882063795349";
/* North Carolina Press Association */
google_ad_slot = "NCPA";
google_ad_width = 300;
google_ad_height = 250;
</script>
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script></div>
      
  </div>
<div id="block-dfptagcnicherokeesidebarnetwork2" class="block block-dfp block-dfp-ad13778503-848d-47bf-9e4e-3302127a4232">
  
    
      <div id="js-dfp-tag-cni_cherokeesidebarnetwork2">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_cherokeesidebarnetwork2');
        });
    </script>
</div>

  </div>

  </aside>

      
    </main>

    <footer role="contentinfo" class="columns border-top-light">
                <div class="region region-footer-left column">
    <div id="block-tiemposcni-contactinformation" class="block block-block-content block-block-contentbb8e208a-8245-4087-b0c0-a5b20e5a2929">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><h3>THE CHEROKEE SCOUT</h3>

<p><strong>Mailing Address:</strong><br />
89 Sycamore St. Murphy, NC 28906<br />
<strong>Phone:</strong> 828-837-5122<br />
<strong>Fax:</strong> 828-837-5832</p></div>
      
  </div>

  </div>

                      <div class="region region-footer-center column">
    <div id="block-tiemposcni-copyrightnotice" class="block block-etype block-copyright-block">
  
    
      <p class="has-text-centered">&copy;&nbsp;2021&nbsp;Cherokee Scout, Murphy, North Carolina</p>
  </div>

  </div>

                      <div class="region region-footer-right column">
      
    <ul class="menu footer-menu is-pulled-right">
          <li class="menu-item">
      <a href="https://nearme.cherokeescout.com/" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif">Marketplace</a>
    </li>
          <li class="menu-item">
      <a href="/contact" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="contact">Contact</a>
    </li>
          <li class="menu-item">
      <a href="/webforms" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="webforms">Webforms</a>
    </li>
          <li class="menu-item">
      <a href="/about" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/969">About Us</a>
    </li>
          <li class="menu-item">
      <a href="/archives" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/973">Archive</a>
    </li>
          <li class="menu-item">
      <a href="/links" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/1497">Links</a>
    </li>
          <li class="menu-item">
      <a href="/cherokee-county-restaurants" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/1713">Menus</a>
    </li>
          <li class="menu-item">
      <a href="/ada-compliance" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="ada-compliance">Accessibility Policy</a>
    </li>
          <li class="menu-item">
      <a href="/nie" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/1717">NIE</a>
    </li>
          <li class="menu-item">
      <a href="/etype-login" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="etype-login">Login</a>
    </li>
          <li class="menu-item">
      <a href="https://www.etypeservices.com/Privacy.aspx" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif">Privacy Policy</a>
    </li>
  </ul>
  





  </div>

          </footer>

    <section id="coupons" class="columns">
          </section>

  </div>
</div>
  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/10304","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"google_analytics":{"account":"UA-26466179-18","trackOutbound":true,"trackMailto":true,"trackDownload":true,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip"},"statistics":{"data":{"nid":"10304"},"url":"\/core\/modules\/statistics\/statistics.php"},"user":{"uid":0,"permissionsHash":"a9bb809a72593f7676c735244b1ad31eea510cca2f0f7ee6320c17079314de37"}}</script>
<script src="/sites/cherokeescout.etypegoogle7.com/files/js/js_aRVJ3MdDVYsxtzIyliTzcm576TFmee9hAxhtWFHgGbw.js"></script>
<script src="https://static.addtoany.com/menu/page.js" async></script>
<script src="/sites/cherokeescout.etypegoogle7.com/files/js/js_1M1dM2o_mIUwU6DFpV2LCjGEz3KdXkIH2j8owBUpVvw.js"></script>
<script src="//use.fontawesome.com/releases/v5.8.1/js/all.js" defer></script>
<script src="/sites/cherokeescout.etypegoogle7.com/files/js/js_aG6XcXyAZs7U4Im5KioyksCFfM_asCiVGoPSfSiJOyc.js"></script>


</body>
</html>
